App not working and throwing issues in development mode


  • [ x ] BUG

What happened:
I cloned the master branch and ran the following commands:

$ git clone
$ cd trudesk
$ npm install -g yarn
$ yarn

and then node app.js to run the application in development mode. I was able to see the server saying Running in: development and the app serving at localhost:8118, but when I click Let’s start, nothing happened. But when I ran the following commands

$ yarn run build
$ node runner

it works fine saying Launching in no daemon mode.

Also in development mode, I was able to see the following error in browser console

Uncaught SyntaxError: Unexpected token < at install:1
install:420 Uncaught TypeError: window.truRequire is not a function
    at install:420
(anonymous) @ install:420

but not in daemon mode.

What did you expect to happen:
The development mode to work like how the daemon worked when node runner was commanded

How to reproduce it (as minimally and precisely as possible):

$ git clone
$ cd trudesk
$ npm install -g yarn
$ yarn
$ node app.js

Anything else we need to know?:


  • Trudesk Version: trudesk v1.0.13
  • OS (e.g. from /etc/os-release): Ubuntu 18.04
  • Node.JS Version: v10.15.3
  • MongoDB Version: v3.6.3
  • Is this hosted on No

Thanks in advance

If you post on github, please do not re-post on the forums.

I answered this already on Github.