Wrong Timezone, Still Back to the Default of -5

What happened:
Wrong time displayed when creating new ticket and when adding comment in a ticket. Even after Timezone changed to Asia/Jakarta, the time still is somehow hardcoded to use the default (America/New_York). Also, in Conversations, when a message is first sent, the timestamp is wrong, but it will display the correct time after refreshing the Conversations page.




Everything else shows the correct time including Dashboard.

What I have tried:

  1. Installation on native Linux Debian and using Docker, tried version 1.1.11, 1.2.0, 1.2.1, 1.2.2
  2. Tried fresh installation as well as upgraded version
  3. Change the timezone and restart the server. Also tried to use a private browsing session to access Trudesk after the restart of the server still producing the same (erroneous) result

Update:
After doing some more testing (on v1.2.2, then updated to v1.2.3), I found that the time display will show correct offset (UTC+7) after refreshing the browser by pressing the F5 (Refresh) key:

  1. After Create Ticket, open the ticket in the Tickets menu, refresh the browser
  2. After Create Ticket and add comments to the ticket, open the ticket in the ticket menu, refresh the browser
  3. After add comments to a ticket, refresh the browser

Then if I go to another ticket, other menu or logout, the time display will go back to UTC-5 offset.

Can you show me your system timezone, so I can troubleshoot accurately?

ie:
cat /etc/timezone

Hi Chris, thanks for your response. I attach the screenshot below:

timedatectl